Unexpected platform outrage

Incident Report for Engiven

Resolved

This incident has been resolved.
Posted Aug 21, 2023 - 14:57 UTC

Investigating

We are investigating platform outage due to a potential database update.
Posted Aug 21, 2023 - 14:44 UTC
This incident affected: Platform.