Unexpected Service Degredation

Incident Report for Engiven

Resolved

This incident has been resolved.
Posted Mar 18, 2026 - 14:39 UTC

Identified

Our upstream exchange provider Gemini is investigating issues that may impact all giving widgets and some endpoints of the API.
Posted Mar 17, 2026 - 18:17 UTC
This incident affected: API and Platform.