Unexpected Outage
Incident Report for Engiven
Resolved
There was a temporary issue with the database session. The issue is now resolved.
Posted Apr 17, 2024 - 22:19 UTC
Investigating
We are currently investigating this issue
Posted Apr 17, 2024 - 22:07 UTC
This incident affected: Platform.