Unexpected Widget Outage

Incident Report for Engiven

Resolved

This incident has been resolved.
Posted Apr 21, 2025 - 19:15 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 21, 2025 - 17:13 UTC

Identified

Our upstream provider Gemini is investigating an issue where customers are unable to create deposit addresses for crypto deposits
Posted Apr 21, 2025 - 17:10 UTC
This incident affected: API, Platform, and GiveToAnyNPO.